cisco vlan - komputer jaringan - Publisher - SMK Negeri 2 Baleendah
Sunday, 2016-12-04, 10:15 PMWelcome Guest | RSS

 SMKN 2 Baleendah
   Official Website
SMKN2Baleendah menu
Section categories
My articles [4]
LINUX [3]
trouble shooting [5]
komputer jaringan [6]
komputer jaringan
website [2]
website
troubleshooting komputer [2]
troubleshooting
tips & trik [4]
tips & trik
macremedia flash [1]
macremedia flash
VIDEO TUTORIAL [4]
VIDEO TUTORIAL
Statistics

Total online: 1
Guests: 1
Users: 0

Publisher


Main » Articles » komputer jaringan

cisco vlan

cisco vlan

VLAN = Virtual Local Area Network

VLAN berguna untuk membagi broadcast domain, membagi berdasarkan job function atau departements tanpa memperhatikan lokasi dari si user dan di Setiap berbeda VLAN itu mempunyai traffic masing2.

Misalkan :

Di suatu gedung ada 3 tingkat, di gedung tersebut mempunyai banyak departemen (keuangan, produksi, IT, Penjualan dan HRD)
keuangan = 10 user
produksi = 10 user
penjualan = 4 user
HRD = 5 user
IT = 3 user
Vlan yg kita create adalah VLAN 10 = keuangan, VLAN 20 = produksi, VLAN 30 = penjualan, VLAN 40 = HRD dan VLAN 50 = IT
Maka disetiap VLAN yg kita create.. mereka mempunyai traffic masing2 dan tidak akan terkirim ke traffic vlan lain (1 VLAN = 1 broadcast domain). Jadi security dan keamanan or privacy data dari masing2 bagian bisa tetap terjaga.


Di suatu gedung ada 3 tingkat, di gedung tersebut mempunyai banyak departemen (keuangan, produksi, IT, Penjualan dan HRD)
keuangan = 10 user (5 user di lt. 1 dan 5 user di lt. 2 )
produksi = 10 user (5 user di lt. 1 dan 5 user di lt. 2)
penjualan = 8 user (4 user di lt. 2 dan 4 user di lt. 3)
HRD = 5 user (5 user di lt. 2)
IT = 3 user (3 user di lt. 3)
Vlan yg kita create adalah VLAN 10 = keuangan, VLAN 20 = produksi, VLAN 30 = penjualan, VLAN 40 = HRD dan VLAN IT = 50
Dengan kebutuhan seperti diatas maka kita membutuhkan 3 switch manageable dan 1 router. Topologinya seperti ini:

-=-=-= Switch =-=-=-
Pada Switch yang harus kita lakukan adalah sbb:
1. Create VLAN
2. Set port Trunk + Assign port utk trunk + set encapsulationnya
3. Assign port untuk setiap VLAN
4. Set port Access

Standarisasi nama PC client V_1.2.3
V = VLAN
1 = VLAN ID
2 = Lantai gedung
3 = Urutan di setiap lantai dan VLAN ID

Standarisasi IP Address pada setiap VLAN
VLAN 10
NETWORK = 192.168.1.0/24
GATEWAY = 192.168.1.1
VLAN 20
NETWORK = 192.168.2.0/24
GATEWAY = 192.168.2.1
VLAN 30
NETWORK = 192.168.3.0/24
GATEWAY = 192.168.3.1
VLAN 40
NETWORK = 192.168.4.0/24
GATEWAY = 192.168.4.1
VLAN 50
NETWORK = 192.168.5.0/24
GATEWAY = 192.168.5.1 Standarisasi Switch_Lt1
Create VLAN 10
Create VLAN 20
fastethernet 0/12 dipakai buat trunk ke Switch_Lt2
fastethernet 0/1 dipakai untuk PC V_10.1.1
fastethernet 0/2 dipakai untuk PC V_10.1.2

fastethernet 0/3 dipakai untuk PC V_20.1.1
fastethernet 0/4 dipakai untuk PC V_20.1.2

Standarisasi Switch_Lt2
Create VLAN 10
Create VLAN 20
Create VLAN 30
Create VLAN 40
fastethernet 0/10 dipakai buat trunk ke Rtr_VLAN
fastethernet 0/11 dipakai buat trunk ke Switch_Lt3
fastethernet 0/12 dipakai buat trunk ke Switch_Lt1
fastethernet 0/1 dipakai untuk V_10.2.1
fastethernet 0/2 dipakai untuk V_10.2.2
fastethernet 0/3 dipakai untuk V_20.2.1
fastethernet 0/4 dipakai untuk V_20.2.2
fastethernet 0/5 dipakai untuk V_30.2.1
fastethernet 0/6 dipakai untuk V_30.2.2
fastethernet 0/7 dipakai untuk V_40.2.1
fastethernet 0/8 dipakai untuk V_40.2.2 Standarisasi Switch_Lt3
Create VLAN 30
Create VLAN 50
fastethernet 0/11 dipakai buat trunk ke Switch_Lt2
fastethernet 0/1 dipakai untuk V_30.3.1
fastethernet 0/2 dipakai untuk V_30.3.2
fastethernet 0/3 dipakai untuk V_50.3.1
fastethernet 0/4 dipakai untuk V_50.3.2

Switch_Lt1:

Switch_Lt1# vlan database
Switch_Lt1(vlan)# vlan 10 name keuangan ==> create vlan 10 dengan nama keuangan
Switch_Lt1(vlan)# vlan 20 name produksi
Switch_Lt1(vlan)# exit
Switch_Lt1# config terminal
Switch_Lt1(config)# interface fastethernet 0/12
Switch_Lt1(config-if)# switchport mode trunk
Switch_Lt1(config-if)# switchport trunk encapsulation dot1q
Switch_Lt1(config-if)# exit
Switch_Lt1(config)# interface fastethernet 0/1
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 10 ==> 10 = VLAN yang kita assignkan di port fastethernet 0/1
Switch_Lt1(config)# interface fastethernet 0/2
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 10
Switch_Lt1(config)# interface fastethernet 0/3
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 20
Switch_Lt1(config)# interface fastethernet 0/4
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 20
Switch_Lt1# copy running-config startup-config

Switch_Lt2:

Switch_Lt2# vlan database
Switch_Lt2(vlan)# vlan 10 name keuangan
Switch_Lt2(vlan)# vlan 20 name produksi
Switch_Lt2(vlan)# vlan 30 name penjualan
Switch_Lt2(vlan)# vlan 40 name HRD
Switch_Lt2# config terminal
Switch_Lt2(config)# interface fastethernet 0/12
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/11
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/10
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/1
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 10
Switch_Lt2(config)# interface fastethernet 0/2
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 10
Switch_Lt2(config)# interface fastethernet 0/3
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 20
Switch_Lt2(config)# interface fastethernet 0/4
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 20
Switch_Lt2(config)# interface fastethernet 0/5
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 30
Switch_Lt2(config)# interface fastethernet 0/6
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 30
Switch_Lt2(config)# interface fastethernet 0/7
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 40
Switch_Lt2(config)# interface fastethernet 0/8
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 40
Switch_Lt1# copy running-config startup-config

Switch_Lt3:

Switch_Lt3# vlan database
Switch_Lt3(vlan)# vlan 30 name penjualan
Switch_Lt3(vlan)# vlan 50 name IT
Switch_Lt3(vlan)# exit
Switch_Lt3# configure terminal
Switch_Lt3(config)# interface fastethernet 0/11
Switch_Lt3(config-if)# switchport mode trunk
Switch_Lt3(config-if)# switchport trunk encapsulation dot1q
Switch_Lt3(config)# interface fastethernet 0/1
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 30
Switch_Lt3(config)# interface fastethernet 0/2
Switch_Lt3(config-if )# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 30
Switch_Lt3(config)# interface fastethernet 0/3
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 50
Switch_Lt3(config)# interface fastethernet 0/4
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 50
Switch_Lt3# copy running-config startup-config

verify pada switch :

Switch# show vlan ==> Lihat semua VLAN yg telah kita create
Switch# show vlan [number] ==> Lihat VLAN ID yang telah kita buat
Switch# show running-config ==> Melihat keseluruhan konfigurasi kita
coba ping dari PC client yg sama VLAN ID, Klo bisa berarti link antar switch dah bisa.

Penjelasan command pada switch :

Switch_Lt3(config)# interface fastethernet 0/2
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan [VLAN ID]

Maksud dari 3 perintah diatas adalah Meng-assignkan port fastethernet 0/2 menjadi milik [VLANID] dan membuat port tersebut mempunyai mode access. That’s means.. port tersebut hanya dapat membawa [VLAN ID]nya saja dan ini penting untuk di terapkan di setiap port yg menuju ke PC Client.

Switch_Lt3(config)# interface fastethernet 0/11
Switch_Lt3(config-if)# switchport mode trunk
Switch_Lt3(config-if)# switchport trunk encapsulation dot1q

Maksud dari 3 perintah diatas adalah Meng-assignkan port fastethernet 0/11 mempunyai encapsulation dot1q dan menjadikan port tersebut menjadi trunk. Trunk means.. pada link port tersebut dia yg bekerja membawa multiple [VLAN ID] dalam satu link. Oleh karena itu Kita bisa berkomunikasi antar VLAN.. dikarenakan ada port yang dijadikan trunk.

-=-=-= Router =-=-=-
Pada Router yang harus kita lakukan adalah sbb:
1. Buat Sub-interface sebanyak VLAN yg telah kita create
2. Set Gateway di setiap Sub-Interface
3. Set Encapsulation sesuai dengan encapsulation yg dipakai di switch

Rtr_VLAN :

Rtr_VLAN# configure terminal
Rtr_VLAN(config)# interface fastethernet 0/0
Rtr_VLAN(config-if)# no shutdown ==> Menghidupkan interface fa0/0
Rtr_VLAN(config)# interface fastethernet 0/0.10
Rtr_VLAN(config-subif)# encapsulation dot1q 10
Rtr_VLAN(config-subif)# ip address 192.168.1.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.20
Rtr_VLAN(config-subif)# encapsulation dot1q 20
Rtr_VLAN(config-subif)# ip address 192.168.2.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.30
Rtr_VLAN(config-subif)# encapsulation dot1q 30
Rtr_VLAN(config-subif)# ip address 192.168.3.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.40
Rtr_VLAN(config-subif)# encapsulation dot1q 40
Rtr_VLAN(config)# ip address 192.168.4.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.50
Rtr_VLAN(config-subif)# encapsulation dot1q 50
Rtr_VLAN(config-subif)# ip address 192.168.5.1 255.255.255.0
Rtr_VLAN# copy running-config startup-config

verify pada router:

Rtr_VLAN# show ip route ==> Terlihat semua network2 yang kita buat
Rtr_VLAN# show running-config ==> Melihat keseluruhan konfigurasi kita


Penjelasan command pada router :

Rtr_VLAN(config)# interface fastethernet 0/0.10
Rtr_VLAN(config-subif)# encapsulation dot1q 10
Rtr_VLAN(config)# ip address 192.168.1.1 255.255.255.0

Keuntungan menggunakan VLAN :

* mudah apabila suatu lan akan dipindahkan
* mudah membuat workstation didalam lan
* mudah mengubah setting lan
* mudah mengamati traffic jaringan
* keamanan terjaga

 

Category: komputer jaringan | Added by: smkn2be (2009-08-11)
Views: 413 | Rating: 0.0/0 |
Total comments: 0
Name *:
Email *:
Code *:
Login form
Search